BoldChat by LogMeIn - Help Center

BoldChat Android SDK

The BoldChat Android Mobile Chat SDK is distributed in the form of an Android Library Project.

Add the BoldChat Android Library Project to your existing project to access our pre-built chat components.

Compatibility

The SDK supports Android 2.3 (Gingerbread) or newer.

Usage

The SDK can be used in the following ways:

  • Via the AppCompat and ActionBarSherlock compatibility libraries
  • Embed as a subview in your existing layouts

The SDK uses a bc_ prefix for ids and resources to prevent potential conflicts. All labels within the Chat SDK are automatically localized in all the BoldChat's supported languages. The localized language will be automatically chosen based on the phone's language and can be changed in the pre-chat form.